• Welcome!
    |
    ||
    Logout|My Dashboard

Update: Is life possible without cable TV? - The Galveston County Daily News : Blogs

September 22, 2014

Update: Is life possible without cable TV?

Print
Font Size:
Default font size
Larger font size

Posted: Friday, January 24, 2014 3:43 pm | Updated: 3:38 pm, Sat Jan 25, 2014.

Update: I promised the Comcast customer service rep I spoke to today that I would continue to blog about my cable problem until I didn't have a problem anymore. And I like to keep my promises.

The On Demand programs keep freezing, pixellating, etc. Although I've had the problem for a month, Comcast will only credit me for a week based on my latest call, which was Jan. 23. 

Maybe that's fair. And maybe I should have called to complain sooner, but I hate being on hold and from past experience, the problem never stays solved for long. 

So, anyway, Comcast offered to send a technician out Monday. But I have work appointments so I declined. I'll have to wait until I can block out several hours of a work week to fix this, but I don't see that happening soon.

I will say, I admire the Comcast rep's ability to stay calm as I fume and threaten to cancel my subscription. It isn't their fault, I know. And I did get really testy. I generally try to stay calm, too. But like most consumers, I want what I pay for, which isn't unreasonable.

Since I can't watch some of the shows I planned to this weekend, I think I'll use that time to reflect on whether I can live without cable TV service.

What's life like without cable TV? Who among you has pulled the plug? What do you do for high-speed Internet service? Is there a better option? 

Previous blog:

Is anyone else having issues with Comcast? Specifically, is anyone else experiencing the problem of TV programs in the On Demand section freezing or pixellating or both?

It’s been going on for weeks at my home. Last night, extremely frustrated, I called a customer service representative, who was very friendly but didn’t help much.

When this has happened before, a representative has advised us to just unplug the power cord to the cable box and plug it back in. This time, the rep said we should unplug the power and the coaxial cable.

That didn’t help either.

I’ve searched online and some consumers say the issue is related to Tivo. I don’t have Tivo.

I'm curious whether this is a widespread problem. Also, if you know how to solve the problem, please let me know.